Slow performance

Incident Report for Aptem Platform

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 15:50 BST

Monitoring

Performance has been restored and we are monitoring the issue.
Posted Apr 20, 2026 - 15:37 BST

Update

We are provisioning additional compute capacity to support better performance for affected tenants, this will result in a short period of unavailability for some customers.
Posted Apr 20, 2026 - 15:28 BST

Investigating

Our monitoring has identified that some users may be experiencing slow page load times, and in some cases white screens or error messages. We are investigating this issue and will provide an update shortly.
Posted Apr 20, 2026 - 14:59 BST
This incident affected: Aptem Apprentice.