Power BI Unavailable

Incident Report for Aptem Platform

Resolved

The incident has been resolved. The issue was caused by high resource usage, which led to Power BI reports loading being throttled. We increased report resources and monitored the situation as usage returned to normal levels.
Posted Jun 26, 2025 - 11:49 BST

Monitoring

Power BI performance is back to normal levels, there should be no delays when loading reports. We’re continuing to monitor to make sure everything stays stable.
Posted Jun 26, 2025 - 11:33 BST

Update

Power BI reports are loading, but a bit slower than usual. We're still looking into what's causing the delay and will share more updates as soon as we have them.
Posted Jun 26, 2025 - 10:45 BST

Investigating

We're aware that customers are currently unable to access their Power BI reports. Our team is investigating the issue and working to resolve it as quickly as possible.
Posted Jun 26, 2025 - 10:11 BST
This incident affected: Data Access.